Speedometer gauge - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 5TH GENERATION HONDA ACCORD (1994-1997) > 5G HONDA ACCORD TECHNICAL DISCUSSION
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old December 6th, 2006, 06:32 AM   #1
 
Join Date: Nov 2004
Posts: 88
Speedometer gauge

My speedodeter gauge is stuck at 20mph. My quess is because it's cold here in Philadelphia. It was fine 2 days ago. Any idea why it is stuck? thanks
Som95ACCORD is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old December 7th, 2006, 01:33 AM   #2
 
Join Date: Nov 2004
Posts: 88
Since it's warmer than yesterday, the gauge is working fine. Also I will let the car warm up alittle longer.
Som95ACCORD is offline   Reply With Quote Quick reply to this message
Old December 9th, 2006, 07:26 PM   #3
Shifting 5 Gears Baby !!
 
cowgodv6's Avatar
 
Join Date: Aug 2002
Location: south shore montreal canada
Posts: 999
Send a message via MSN to cowgodv6
check da pms
pretty sure is the speedo sensor on the brakes.
the sensor has solenoids and relays around the eletrical run it has, so I would check there, could be a un-clipped or loss of contact
__________________
My Rides :
95 Accord EX-R V6 ( C27M5 ) 5 Speed feels so good !!!
93 Civic Si Coupe ( D16Z8 )
92 Civic LX 4 door Winter Beater - Wife`s winter car (scrapped)
92 Accord EX - Winter Beater
cowgodv6 is offline   Reply With Quote Quick reply to this message
 
Old March 6th, 2007, 11:24 AM   #4
 
Join Date: Oct 2004
Posts: 86
Quote:
Originally Posted by cowgodv6
check da pms
pretty sure is the speedo sensor on the brakes.
the sensor has solenoids and relays around the eletrical run it has, so I would check there, could be a un-clipped or loss of contact


I have taken the gauge cluster completely apart on my car.. I put leds in it.. any way.. if the gauge is sticking with the key in the OFF position it is the gauge. Take the cluster out and remove the speedometer. There are two little bushings on it.. on under the needle and one in the back under the circuit board. Lube it with some motorcycle cable lube( has a nice needle on it) and make sure the needle moves freely. It should move when you tip the cluster upside down. Just make sure the needle is resting on it's stop when you put it all back together. IF it still sticks you may need to replace the speedometer. If your VSS (vehicle speed sensor) is not working the transmission will shift rough and at odd times and at high revs. and there will be a check engine light on.
97accord-ex-v6 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On