Car feels loose under high speeds. - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 7TH GENERATION HONDA ACCORD (2003-2007) > 7G HONDA ACCORD PERFORMANCE DISCUSSION
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old April 3rd, 2015, 09:11 AM   #1
Registered User
 
StrtRcr4Lf's Avatar
 
Join Date: Jul 2008
Location: Columbia, SC
Posts: 353
Car feels loose under high speeds.

So lately my car has been feeling loose when I turn and brake under high speeds. It sort of feels like my rear end is "wagging its tail".
I have tein SS
Michelin pilot sport a/s
And also Ingalls rear camber kit
Along with TL type R sway bar

Any suggestions on what I should check?
StrtRcr4Lf is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old April 3rd, 2015, 09:28 AM   #2
Registered User
 
thisaznboi88's Avatar
 
Join Date: Dec 2007
Location: West Virginia
Posts: 8,733
ingalls rear camber bushing turned to ****. They are probably donut
thisaznboi88 is offline   Reply With Quote Quick reply to this message
Old April 3rd, 2015, 09:29 AM   #3
Registered User
 
StrtRcr4Lf's Avatar
 
Join Date: Jul 2008
Location: Columbia, SC
Posts: 353
If that's the case, what do you recommend. Should I get a different kit or just replace the bushings
StrtRcr4Lf is offline   Reply With Quote Quick reply to this message
 
Old April 3rd, 2015, 12:36 PM   #4
Registered User
 
Join Date: Jun 2010
Posts: 155
Yea it is the ingalls arms. They are garbage. Go with oem, hardrace, etc. There was a group buy for some custom spherical arms on here. I picked up a set of those and run Hardrace spherical arms now.
brian6speed is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On