Need Help NOW!!! - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 7TH GENERATION HONDA ACCORD (2003-2007) > 7G HONDA ACCORD PERFORMANCE DISCUSSION
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old August 2nd, 2005, 11:04 AM   #1
Registered User
 
Join Date: Nov 2004
Posts: 109
Angry Need Help NOW!!!

Last night, i was driving my car. I recently purchased new brakes and got my rotors machined all around. So i was decided to test my new brakes. So on a empty back road, I sped up to 70. And just slammed on the brakes. It took me sooo long to stop. The brakes went to the FLOOR. The ABS didn't kick in, nor did the tires lock. The brakes just went to the floor and i kept rolling. is there a problem with my ABS? Why didn't the tires lock up? What would happen if i had to slam on brakes to stop from hitting someone?
mahdigga is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old August 2nd, 2005, 11:19 AM   #2
 
Join Date: Nov 2004
Posts: 350
thats when you hit the E brake and drift around the car.
RentsDidntBuyIt is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 11:21 AM   #3
Registered User
 
Andrea's Avatar
 
Join Date: Apr 2003
Location: Bay Area
Posts: 98
first, new brakes have to be "broken in" first. no hard braking (unless necessary)

Quote:
The brakes just went to the floor and i kept rolling
you need to bleed the brakes some more(frequent tap on the brake pedals). air bubbles might be present on the lines.
Andrea is offline   Reply With Quote Quick reply to this message
 
Old August 2nd, 2005, 11:22 AM   #4
Registered User
 
Join Date: Nov 2004
Posts: 109
But why didn't they lock up?? the ABS didn't kick in
mahdigga is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 11:28 AM   #5
Registered User
 
Andrea's Avatar
 
Join Date: Apr 2003
Location: Bay Area
Posts: 98
if you tested your brakes right after the you replaced them, then there is a possibility that air bubbles in the brake lines are not yet removed (bleed). tapping the brake pedal should take care of that unless the mechanic did a horrible job installing.

there is no pressure on the brake lines if bubbles are present because the brake fluid should "push" the brake discs. your brake pedal went all the way to the floor because of the air japs in the brake lines.
Andrea is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 11:29 AM   #6
Nothing special
 
blu6speed's Avatar
 
Join Date: Nov 2003
Location: Maryland
Posts: 838
Send a message via AIM to blu6speed
Well for starters, you have to give brakes break in time!!! or else your going to be getting them turned down again.

1. Check the brake fluid level. They may have bled the brakes and not replaced the correct amount of lost fluid.

2. With thinner rotors, your pedal is going to go further down, you have to push the pistons on the brakes out further for them to come in contact with the rotors.

3. Sit at a stop with the car running, press the brake. If the pedal stops, then slowly sinks, you have air in the lines and they need bled.

If its as bad as you say, take it back to where you had the work done and get them to fix whatever the problem may be.
__________________
2003 Blue Accord Coupe EX V6 6-Speed
blu6speed is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 11:31 AM   #7
Registered User
 
Raddy21's Avatar
 
Join Date: Oct 2004
Location: Bethesda, MD
Posts: 1,136
how long do brakes take to break in? just curious b.c i recently installed new pads and they dont feel as good as they should yet imo.
thanks
Raddy21 is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 11:31 AM   #8
I'm stupid with cars
 
Showtime's Avatar
 
Join Date: Aug 2003
Location: Irvine
Posts: 610
Send a message via ICQ to Showtime Send a message via AIM to Showtime
Showtime is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 12:21 PM   #9
Registered User
 
Join Date: Nov 2004
Posts: 109
I had my brakes for about a week. Isn't that enough break in time?
mahdigga is offline   Reply With Quote Quick reply to this message
Old August 2nd, 2005, 01:19 PM   #10
constantly in pursuit
 
hammer03's Avatar
 
Join Date: Nov 2004
Location: Santa Barbara
Posts: 4,250
Send a message via AIM to hammer03
i think i heard a hundred miles or so? last time i had mine done. i think thats what they told me.
hammer03 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On