Recurring P420 code w/ freeze frame data - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 7TH GENERATION HONDA ACCORD (2003-2007) > 7G HONDA ACCORD TECHNICAL DISCUSSION
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old July 27th, 2014, 02:28 PM   #1
Registered User
 
Join Date: Jan 2011
Posts: 313
Recurring P420 code w/ freeze frame data

So my car has a recurring P420 code. Its been on for about 6 months. This weekend I had a new starter put in because it was going out, also cleaned the air filter box out, cleaned the IAT sensor, and the air intake tube and replaced the air filter. Afterwards, the CEL went off and my friend Amber (who is a mechanic) reset the maintenance light so it would go off.

We drive from Denver to Montrose, CO yesterday to see the Black Canyon of the Gunnison. Before we left we poured some sea foam through the intake and some in the gas tank to clean everything out in the engine and gas tank and injectors. She ran like a champ most of the day, till halfway back to Denver the CEL light came on again and the idle was a bit rough.

Hooked the obdII scanner up and it gave me the code plus freeze frame data of the engine when the fault occurred.




















anyone know whats going on here?

Last edited by WyattEarp; July 27th, 2014 at 03:39 PM..
WyattEarp is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old July 27th, 2014, 04:02 PM   #2
Registered User
 
accord325's Avatar
 
Join Date: Jul 2012
Location: Tampa
Posts: 2,392
Don't quote me on this but I think your front bank cat (or one of them) is taking a crap.
accord325 is offline   Reply With Quote Quick reply to this message
Old July 27th, 2014, 04:56 PM   #3
Registered User
 
Join Date: Jan 2011
Posts: 313
i looked under my car, all it shows is one catalytic converter. is that all I need?
WyattEarp is offline   Reply With Quote Quick reply to this message
 
Old July 28th, 2014, 12:17 PM   #4
Registered User
 
Join Date: Jan 2011
Posts: 313
anyone else?????
WyattEarp is offline   Reply With Quote Quick reply to this message
Old July 28th, 2014, 12:40 PM   #5
Registered User
 
thisaznboi88's Avatar
 
Join Date: Dec 2007
Location: West Virginia
Posts: 8,733
His a 4 banger so yes the cat under your car
thisaznboi88 is online now   Reply With Quote Quick reply to this message
Old July 28th, 2014, 02:33 PM   #6
Registered User
 
accord325's Avatar
 
Join Date: Jul 2012
Location: Tampa
Posts: 2,392
Lol, didn't read his sig.
accord325 is offline   Reply With Quote Quick reply to this message
Old August 3rd, 2014, 03:24 PM   #7
Registered User
 
Join Date: Aug 2014
Location: Stillwater, MN
Posts: 13
That freeze frame data is meaningless for that code. You need to compare your o2 sensors to see if they are switching the same. If so then your probably will need a cat.
Beefcake17 is offline   Reply With Quote Quick reply to this message
Old August 25th, 2014, 08:14 PM   #8
Registered User
 
Join Date: Jan 2011
Posts: 313
cat replaced. code gone.
WyattEarp is offline   Reply With Quote Quick reply to this message
Old August 26th, 2014, 08:56 AM   #9
Registered User
 
accord325's Avatar
 
Join Date: Jul 2012
Location: Tampa
Posts: 2,392
Good to hear everything worked out and we could help
accord325 is offline   Reply With Quote Quick reply to this message
Old August 26th, 2014, 10:03 AM   #10
Registered User
 
bozos_si's Avatar
 
Join Date: Jul 2009
Location: North minneapolis, MN
Posts: 934
How many miles you have on this? I have rarely heard of a cat going bad unless the car was super old or super high in miles.
bozos_si is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On