Tried installing camber kit - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 7TH GENERATION HONDA ACCORD (2003-2007) > 7G HONDA ACCORD WHEELS, TIRES, & SUSPENSION DISCUSSION
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.

Reply
 
LinkBack Thread Tools Display Modes
Old June 5th, 2005, 06:57 PM   #1
Registered User
 
Join Date: Jul 2003
Posts: 430
Tried installing camber kit

Argh... tried installing the Ingalls cambler kit. Left-center-lower link came out fine, but the other three are stuck solid. I can get the bolts fine out on the axle side but on the body side the bolt is rusted solid right inside the rubber piece in the link.

I tried hammering the $hit out of it, WD40... everything but it's still stuck solid.

My next step is to simply cut them (and therefore messing up the factory links... no big deal).

Any other suggestions before I do that?
herzzreh is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 5th, 2005, 07:00 PM   #2
Senior Member
 
driven's Avatar
 
Join Date: Jan 2003
Location: Maryland
Posts: 4,406
Send a message via AIM to driven
Quote:
Originally Posted by herzzreh
Argh... tried installing the Ingalls cambler kit. Left-center-lower link came out fine, but the other three are stuck solid. I can get the bolts fine out on the axle side but on the body side the bolt is rusted solid right inside the rubber piece in the link.

I tried hammering the $hit out of it, WD40... everything but it's still stuck solid.

My next step is to simply cut them (and therefore messing up the factory links... no big deal).

Any other suggestions before I do that?
did you try using a large 1/2 inch breaker bar. You can remove almost anything if you use a big enough breaker bar and the bolt isnt rounded off. If you dont have a breake bar, put a metal pipe on your ratchet or open ended wrench to help loosed the nut or bolt. Goodluck -J
driven is offline   Reply With Quote Quick reply to this message
Old June 5th, 2005, 07:18 PM   #3
Registered User
 
Join Date: Jul 2003
Posts: 430
Quote:
Originally Posted by driven
did you try using a large 1/2 inch breaker bar. You can remove almost anything if you use a big enough breaker bar and the bolt isnt rounded off. If you dont have a breake bar, put a metal pipe on your ratchet or open ended wrench to help loosed the nut or bolt. Goodluck -J
Oh, I got the nut off fine, it's just that the bolt is pretty much stuck in a sealed chamber, so to say.
herzzreh is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On