replacing ABS module / hydraulic unit - how to? - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 7TH GENERATION HONDA ACCORD (2003-2007)
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By thisaznboi88

Reply
 
LinkBack Thread Tools Display Modes
Old September 21st, 2014, 01:53 PM   #1
Registered User
 
Join Date: May 2005
Location: Toronto, ON
Posts: 43
replacing ABS module / hydraulic unit - how to?

My 2004 Accord V6 Automatic Coupe with 230k km /142k miles has a tendency to throw the hazard / TCS / ABS warning lamps after a long drive (drives beyond 500km / 310 miles). The car then goes into a dangerous limp-mode which cuts power and causes the vehicle to act jerky.

I replaced the ABS wheel sensors but the issue persists.

I am thinking it is the ABS computer / module / hydraulic unit.

Has anyone replaced this unit before? How difficult is the replacement? Any tips or guides? Any re-programmed required by the dealership?
__________________
1999 Camaro SS 6-speed Coupe
2004 Accord EX-L V6 Auto Coupe
kingrukus is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 7th, 2015, 01:27 PM   #2
Registered User
 
Join Date: Jun 2012
Location: Denver, CO
Posts: 375
not sure if your still around but i'm going through the same thing and doing it backwards

bought ABS Modulator and didn't do it for mine...getting wheel speed sensors
2i2dk1ny2i3 is offline   Reply With Quote Quick reply to this message
Old June 8th, 2015, 05:20 PM   #3
Registered User
 
Join Date: May 2005
Location: Toronto, ON
Posts: 43
I replaced the ABS computer/modulator and the problem went away thankfully. Drove it from Toronto to NYC without any issues.
kingrukus is offline   Reply With Quote Quick reply to this message
 
Old July 20th, 2015, 07:20 PM   #4
VTEC PWNES ALL
 
2muchbass's Avatar
 
Join Date: Aug 2010
Location: Nassau, Bahamas
Posts: 239
any pics or write up on the install?
2muchbass is offline   Reply With Quote Quick reply to this message
Old August 13th, 2015, 08:11 AM   #5
Registered User
 
Join Date: May 2005
Location: Toronto, ON
Posts: 43
Quote:
Originally Posted by 2muchbass View Post
any pics or write up on the install?
Sorry I had my mechanic install it, but it doesn't look like it would be difficult.

However the TCS / Hazard / CEL lamps came on this morning and the car went back into limp mode.

Wonder what the problem is now?
__________________
1999 Camaro SS 6-speed Coupe
2004 Accord EX-L V6 Auto Coupe
kingrukus is offline   Reply With Quote Quick reply to this message
Old August 13th, 2015, 10:43 AM   #6
Registered User
 
thisaznboi88's Avatar
 
Join Date: Dec 2007
Location: West Virginia
Posts: 8,733
Check your brake light switch.
qnzthg89 likes this.
thisaznboi88 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On