2004 V6 Transmission Problems - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 7TH GENERATION HONDA ACCORD (2003-2007)
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old October 23rd, 2016, 08:42 PM   #1
Registered User
 
Join Date: Oct 2016
Posts: 1
2004 V6 Transmission Problems

My '04 Accord V6 with 262k miles is having transmission issues for the first time. From what I've read on here, I've been very fortunate.

Going up a hill, the car hesitated and felt like it went into neutral when trying to shift from third to second gear. The "D" light started blinking and the car would not move. After turning the car off for about 15 minutes, it worked fine to get it home. I changed the transmission fluid, but it did the same thing again. After driving it for about 5 minutes, the car stopped pulling in any gear. It cooled down for 10 minutes and ran fine. I had a scanner hooked to it. The only code that came up was P0721 Output Speed Sensor Range/Performance. Does anyone have experience to know whether the speed sensor will help or if my transmission just needs rebuilt?

Thanks
ashley is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old October 26th, 2016, 03:54 PM   #2
Mr. Detail
 
Scottwax's Avatar
 
Join Date: Sep 2011
Location: Arlington, TX
Posts: 1,112
What did the drain plug look like when you changed the fluid? If it looked like a chia pet, you can bet you've got a lot of crap floating around in the transmission. And that could be why after you let it sit for a while it drives okay again. All the crap stuck to the bottom of the pump falls back down again and restores hydraulic pressure.

The sensor you talk of, I believe it determines if the car's speed matches what the transmission is doing so it really isn't something that controls it but monitors it.
Scottwax is offline   Reply With Quote Quick reply to this message
Old December 22nd, 2016, 07:49 PM   #3
Registered User
 
salcuta88's Avatar
 
Join Date: Jan 2015
Location: Asheville, NC
Posts: 21
Have you ever replaced your oil pressure switches in the transmission? 3rd and 4th gear switches.
salcuta88 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On