2014 accord Breaks please help - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > 9TH GENERATION HONDA ACCORD (2013+)
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old February 2nd, 2017, 10:36 PM   #1
Registered User
 
Join Date: Feb 2017
Posts: 1
2014 accord Breaks please help

Hi guys

I need any thought on what could be wrong or what can I do to fix it. I bought new rotors and pads for my car. I got EBC Ultimax Slotted Rotors - Front Rotor Set, EBC Ultimax Slotted Rotors - Rear Rotor Set
and EBC green stuff pads all around. So I have put on about now 2,000 miles on it I never actually went fast with them just worry if it would stop or not. But today I stated off at a light with tlx and went to like 115mph and when I break slowly it work fine, than I was cruising to the red light and I went to press the break and it was like I had no break luckily it was green light and where I was going was right there. But this has never happen before, the break has been amazing stop instantly driving in normal conditions but does anyone have any idea why this may happen? I have not driving it tonight but will update tomorrow what happens. Thanks
deepm0908 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old February 3rd, 2017, 08:51 PM   #2
Registered User
 
accord325's Avatar
 
Join Date: Jul 2012
Location: Tampa
Posts: 2,394
Well I can speak to the brakes (not breaks

Sound like you have air in the system,need to bleed the brakes. There could also be a pin hole in a line that's letting air in, so go over all hoses/lines.
Also check your fluid level
accord325 is offline   Reply With Quote Quick reply to this message
Old February 4th, 2017, 07:24 AM   #3
Registered User
 
Join Date: Oct 2016
Posts: 6
bleeding the brakes can solve this,mostly because of you got air in the system
Gorg.loes is offline   Reply With Quote Quick reply to this message
 
Old September 13th, 2017, 06:38 AM   #4
Registered User
 
Join Date: Sep 2017
Posts: 2
What did the pedal feel like when you tried to stop harder? Was it mushy? Sink to the floor? Or did you have a nice hard pedal? At first I was wondering if you'd properly bedded in the brakes but EBC's have that coating to ensure a good (and fast) bed-in. Plus with 2k mi on them, I doubt you didn't have proper pad transfer onto the rotor. Were you able to activate the ABS by pushing hard enough like during an emergency stop? If you can't activate them, then something is wrong and you need to get it fixed for your safety.
KDiggityDog76 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On