Issue with 99 Chevy Cavalier blinker - Honda Accord Forum : V6 Performance Accord Forums
Ribbon Banner

Go Back   Honda Accord Forum : V6 Performance Accord Forums > CAR SPECIFIC DISCUSSION > OTHER V6 AUTOMOBILE DISCUSSION > GM, GMC, and PONTIAC
Register FAQ Members List Calendar Mark Forums Read Insurance
V6Performance.net is the premier Honda Accord Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old November 22nd, 2007, 08:03 AM   #1
2009 NL East Champs?
 
Crombie's Avatar
 
Join Date: Sep 2003
Location: Lexington Park, MD
Posts: 32
Send a message via AIM to Crombie Send a message via Yahoo to Crombie
Issue with 99 Chevy Cavalier blinker

My girlfriends 1999 Chevy Cavalier has an issue with the front left blinker. When you start up the car the left blinker light is lit up on the instrument panel (when the blinker is off). When you turn your left blinker light on, it flashes rapidly and makes a very quick sounding clicking sound. NOW: the front AND rear blinker bulbs WORK. My question is... a coworker of mine told me that there is a turn signal flasher that is more than likely the culprit. Does anyone know where it's located in the car?
Thanks!
Crombie is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old December 9th, 2007, 12:40 PM   #2
Registered User
 
97accord-ex-v6's Avatar
 
Join Date: Oct 2004
Location: Casper Wyoming
Posts: 86
Had this happen with a Ford tauris once. One would turn on the headlights and the blinker arrow would come on and stay on. I traced it to a short inside if the front turn signal bulb holder. Try unplugging the bulb holders (not just the bulb) and see if the problem goes away.
97accord-ex-v6 is offline   Reply With Quote Quick reply to this message
Old December 9th, 2007, 04:30 PM   #3
2009 NL East Champs?
 
Crombie's Avatar
 
Join Date: Sep 2003
Location: Lexington Park, MD
Posts: 32
Send a message via AIM to Crombie Send a message via Yahoo to Crombie
Quote:
Originally Posted by 97accord-ex-v6 View Post
Had this happen with a Ford tauris once. One would turn on the headlights and the blinker arrow would come on and stay on. I traced it to a short inside if the front turn signal bulb holder. Try unplugging the bulb holders (not just the bulb) and see if the problem goes away.
I'll try that. Thanks!
Crombie is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Accord Forum : V6 Performance Accord Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Chapter
Choose your AV6 Chapter Location
Ride
What do you drive?
Insurance
Please select your insurance company (Optional)

Log-in


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On