Accord V6 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
OK, this has progressively gotten worse but the long and the short of it is my car stalls unexpectedly while driving. I've got a 99 Acoord Coupe EX V6. I can be accelerating off a stop light and bam it'll stall, sometimes I have to shift to neutral and turn the key or other times I can just keep my foot on the gas and it'll fire back up. Very weird and totally unpredicatable, but very dangerous. I haven't had the ignition switch done, but I can't shift from park w/out hitting the brake and various other tell tale signs the switch is bad... SO should I go have the recall done, or is my problem from something else? PLEASE HELP!



Adam
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #3 ·
maying856 said:
All i can say is bring it to a mechanic or back to the dealership if u still have warranty
Ha, 108K and a salvage title... BUT I have done all the things I should have. I've done timing belt, water pump, crank seal, plugs/wires/cap, and any other maintenance I could find recommended. It was wrecked in the front passenger corner though, and no mechanical damage. From my investigation it was female driven for the first 70K and we've (dad & I) have put the additional 38K w/out much repair. EGR is all I can think of beyond routine stuff and MODS :D


Adam
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #5 ·
maying856 said:
Hmm....try main relay and perhaps alternator and battery
Battery and alternator new within last 10K... main relay perhaps, but what's your take on the ignition switch? :confused:
 

·
Registered
Joined
·
2,629 Posts
^^Its possibly, I would consider everything right now since you say ur car has been checked. But still double check to make sure, bc u never know. Get your electrical system checked and stuff. Regarding the switch, im not sure on that, bc if there was a problem with that, you shouldnt even be able to turn it on.
 

·
its my Religion
Joined
·
1,393 Posts
ok this also happened to me on my 97 prelude I was like wtf is going on, so I went to the dealer and asked if there was a recall on the lude with the same synthoms you described and they said the ignition switch is causing this to happened and yes there was a recall so they fixed it for free and never had that problem since. hope this helps
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #9 ·
OK, forgot to give an update... I took it to the stealership and the guy was a ****. The recall about the ignition switch was supposedly already done and I asked if he thought the switch could go bad again and he kind of laughed and he said he'd never seen another go bad. Also, he said they could not perform any diagnostics on my car b/c it has a cold air intake which in his opinion is probably causing all my problems anyways. I proceeded to tell him the CAI has been on for a year and half with no problems until about a month and half ago. He insisted it was the CAI and I engaged the VTEC and busted out of there :burnout: Luckily, it did not stall on my impressive and mature departure, but all in all I'm still not 100% confident in the car. Does anybody think it could be the main relay which was also mentioned in this post? No CE light and no other tell tale signs of a problem. Thanks again all for the insight... at least you guys can give me some input even with my COLD AIR INTAKE :rolleye2:
 

·
its my Religion
Joined
·
1,393 Posts
danm your dealer sucks, mine did the fix and my car had headers, intake, exhaust etc. just get the ig switch and have some body put it in.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #11 ·
hondaism said:
danm your dealer sucks, mine did the fix and my car had headers, intake, exhaust etc. just get the ig switch and have some body put it in.
Yeah, I almost called Honda of America and pleaed my case but since the car is a salvage title I thought I'd have even less of a leg to stand on. I'm not intimidated by doing any of the work on the car myself, but I thought if I get it done for free then hey :cheers: Thanks for the insight.




Adam
 

·
Registered
Joined
·
1,392 Posts
ok..could either be ignition (coil, switch, relay) or fuel delivery (pump, filter, fuel lines, injectors) or a ping pong ball in ur gas tank
 
1 - 12 of 12 Posts
Top