Accord V6 Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
250 Posts
Discussion Starter #1
so ive been getting horrible gas mileage on my 07 accord i4 ~24k miles. about 15mpg mostly city. one of my friends suggested that the thermostat may be bad. what do you guys think? is it easy/cheap to replace?
 

·
Registered
Joined
·
250 Posts
Discussion Starter #3
but i only have 24k miles on it. do the o2 sensors go bad that easy? are they covered under warranty? i was going to swing by the dealer the other day to check on it but they wanted $90 just to "diagnose" it. so i said forget it.

wow i used alot of "its" in that sentence....
 

·
Registered
Joined
·
160 Posts
i have never truely seen a honda thermostat fail.unless its got 150k plus.i never replaced one....02 sensor if theres any issue with an o2 your gonna get a engine light.possible bad gas, do you start ur car and let it warm up in the morning?or do you drive the hell out of it.lol.
 

·
Bobby Lane Racing
Joined
·
5,679 Posts
i have never truely seen a honda thermostat fail.unless its got 150k plus.i never replaced one....02 sensor if theres any issue with an o2 your gonna get a engine light.possible bad gas, do you start ur car and let it warm up in the morning?or do you drive the hell out of it.lol.
Often times the o2 sensor won't throw a code. The ecu reads it based on range and unless it passes a range or unplugged or bad noCEL will occur
 

·
Registered
Joined
·
1,296 Posts
^^ +1 I had a bad o2 sensor but it didnt throw a code. Only way to really know is take it out and look at it. That still is not a perfect way but it cant help to do a physical inspection.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #8
yea i always thought i would get some kind of light/code if an o2 sensor is bad, so i never thought that would be the problem. are those sensors covered under warranty? cause theyre pretty pricey.. especially like 4 of them or something? not sure how many there are in the car haha. and i usually dont let it warm up cause ive seen a few threads saying warming up the car isnt really needed for newer cars? maybe ill let it warm up for a few minutes before moving from now on..
 

·
Registered
Joined
·
1,296 Posts
yea i always thought i would get some kind of light/code if an o2 sensor is bad, so i never thought that would be the problem. are those sensors covered under warranty? cause theyre pretty pricey.. especially like 4 of them or something? not sure how many there are in the car haha. and i usually dont let it warm up cause ive seen a few threads saying warming up the car isnt really needed for newer cars? maybe ill let it warm up for a few minutes before moving from now on..
Normally o2 sensors are not covered under warranty unless throwing a code during your warranty period. However since you have such low mileage I would take your car to your dealer and see what they say. Please keep us posted on your outcome.
 

·
Registered
Joined
·
4,828 Posts
Hmmm......this might be my problem too. I have a CEL that has came on 3x every ~1K miles for the past 3K. I've also been getting bad gas mileage, around 275 to a full tank. I drive spiritedly but not all the time. I used to get at least 330-350. I'll have to check mine!
 

·
Registered
Joined
·
415 Posts
Hmmm......this might be my problem too. I have a CEL that has came on 3x every ~1K miles for the past 3K. I've also been getting bad gas mileage, around 275 to a full tank. I drive spiritedly but not all the time. I used to get at least 330-350. I'll have to check mine!
i have this exact same problem and i have an AT av6 coupe 2003. is there a procedure in determining if the o2 is going bad? can i find out by going to autozone and getting the code read? im getting 270 to a full tank and i dont think i drive very aggressively especially since i got the drop. i got an alignment just in case to see if thats causing the bad gas mileage but im still getting 270 to a tank.
 

·
Registered
Joined
·
61 Posts
Check owners manual or call Honda, I'm pretty sure the emmisions parts have a factory extended warrenty way past the 36/36 warrenty.
 

·
Registered
Joined
·
415 Posts
i know this isnt the proper way but i just wait until fuel light comes on, fill her up and then clear the mileage just to get a general idea of how much im getting. when i first got the car she was ~310 to a full tank.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #16
Fill my tank all the way up, reset odo, and drive until my next fill up, divide miles driven by the amount of the 2nd fill up. So I usually get around 210-220 miles out of one fill up (I try not to drive to the light, probably around 2 "bars") and fill up around 13 gallons. So around 16mpg.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #20
called dealer, wanted $90 to "check it", went to mechanic i usually go to and asked about the o2 sensors, said thats probably not the reason why since theres no light. told me to try using 93 gas. and my TL-S rims may be one of the causes as well.. regular gas + TL-S + city driving = 16 mpg?
 
1 - 20 of 25 Posts
Top