Accord V6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
engine: j30a4 6mt cm8 chassis

anyone ever had issues with a rocker arm being stuck in place? i have a 3500 limiter and code p2649, solenoid has been replaced, filter is clean and not clogged, wiring to solenoid has been looked at by a specialist and it is fine, oil has been checked everyday since it started and is always the right level, even replaced it last night, is it even possible for a rocker arm to be stuck closed? note: the car starts normal no limp mode, as soon as power goes to the wheels the TCS and warning light comes on and it gives me a 3500 rpm limiter, it doesn’t misfire , it literally sounds like it’s hitting redline
 

·
Registered
Joined
·
15 Posts
engine: j30a4 6mt cm8 chassis

anyone ever had issues with a rocker arm being stuck in place? i have a 3500 limiter and code p2649, solenoid has been replaced, filter is clean and not clogged, wiring to solenoid has been looked at by a specialist and it is fine, oil has been checked everyday since it started and is always the right level, even replaced it last night, is it even possible for a rocker arm to be stuck closed? note: the car starts normal no limp mode, as soon as power goes to the wheels the TCS and warning light comes on and it gives me a 3500 rpm limiter, it doesn’t misfire , it literally sounds like it’s hitting redline
I had a similar issue. replaced the vtec solenoid, filter, gasket, and even the sensor on it. That didn't fix it. What did was a valve adjustment on both banks. Surely enough, the exhaust valves were super tight. That cleared it up. Also, if this doe not work check your oil pressure. Need to make sure plenty is flowing through when engaging vtec.
 
1 - 3 of 3 Posts
Top